информационная безопасность
без паники и всерьез
 подробно о проектеRambler's Top100
Страшный баг в WindowsВсе любят мед
BugTraq.Ru
Русский BugTraq
 Анализ криптографических сетевых... 
 Модель надежности двухузлового... 
 Специальные марковские модели надежности... 
 Phrack #70/0x46 
 Возможно, Facebook наступил на... 
 50 лет электронной почте 
главная обзор RSN блог библиотека закон бред форум dnet о проекте
bugtraq.ru / форум / operating systems
Имя Пароль
ФОРУМ
все доски
FAQ
IRC
новые сообщения
site updates
guestbook
beginners
sysadmin
programming
operating systems
theory
web building
software
hardware
networking
law
hacking
gadgets
job
dnet
humor
miscellaneous
scrap
регистрация





Легенда:
  новое сообщение
  закрытая нитка
  новое сообщение
  в закрытой нитке
  старое сообщение
  • Напоминаю, что масса вопросов по функционированию форума снимается после прочтения его описания.
  • Новичкам также крайне полезно ознакомиться с данным документом.
[Windows 6.0.x] Далеко уже не первый опыт... 19.12.08 15:20  Число просмотров: 2762
Автор: Den <Denis> Статус: The Elderman
Отредактировано 19.12.08 17:05  Количество правок: 1
<"чистая" ссылка>
> Зачем делать разделом C: раздел, в котором находится
> загруженная система? Это такая заплатка для кривописных
> программ, которые умеют работать только с C:?

Мне таки удалось, используя OPK, установить Висту в логический раздел внутри extended раздела и обозвать раздел с системой той буквой, которой нужно мне.
Пока эксперементировал, словил очень интересный баг:
В файле ответов для установки Win6.0 - autounattended.xml, в имени пути хранения пользовательских профилей случайно впечатал "/" вместо положенного "\". Так как NT5+ частично поддерживают данную нотацию, то предустановка Висты прошла на ура, а вот некоторые драйверы и обновления ОС (в т.ч. SP1), которым необходим доступ к профилю пользователя, ставиться наотрез отказались. Я очень долго не мог понять почему SP1 в самом конце установки выдает ошибку и откатывается, т.к. выплевываемые установщиками сообщения об ошибках и журнал событий не содержали полезной информации, пока случайно не стал ставить программу, явно выругавшуюся на то, что не может найти сетевой ресурс "e:/Users". Замена "/" на "\" в значении параметра "ProfilesDirectory" файла ответов и переустановка Висты решила проблему.

Также несколько багов словил при попытке произвести небольшой ручной тюнинг tcp/ip и rpc в Win6.0, а конкретно Windows Server 2008 SP1:
1. При указании IGMPLevel = 1, DHCP, по какой-то непонятной мне причине, отказался привязываться к какому-либо интерфейсу, валился с ошибкой "The DHCP service is not servicing any DHCPv4 clients because none of the active network interfaces have statically configured IPv4 addresses, or there are no active interfaces." и рабочие станции перестали получать IP адреса. Естественно, что возвращение параметра в значение по-умолчанию + перезагрузка вернули все на свои места.

2. Изменение параметра IPConfigurationEnabled = 0, толи более ни на что не влияет, толи состояние APIPA Enabled теперь не возможно проверить через ipconfig /all (Autoconfiguration Enabled там всегда YES).

3. Установка интерфейсов для прослушивания по 135 порту (epmap/rpc) через "rpccfg /a" или "netsh rpc add" теперь приводит к сбою запуска RPCSs и, как следствие, невозможности нормальной загрузки ОС. Возможно это связано с внесенными изменениями в стек tcp/ip и добавлением хост-адаптера, призрак которого "0.0.0.0" можно наблюдать при выполнении команды "netstat -a".
<operating systems> Поиск 








Rambler's Top100
Рейтинг@Mail.ru


  Copyright © 2001-2021 Dmitry Leonov   Page build time: 0 s   Design: Vadim Derkach