информационная безопасность
без паники и всерьез
 подробно о проектеRambler's Top100
Портрет посетителяSpanning Tree Protocol: недокументированное применениеАтака на Internet
BugTraq.Ru
Русский BugTraq
 Анализ криптографических сетевых... 
 Модель надежности двухузлового... 
 Специальные марковские модели надежности... 
 Линуксовый ботнет, распространяющийся... 
 Конец поддержки Internet Explorer 
 Рекордное число уязвимостей в 2021 
главная обзор RSN блог библиотека закон бред форум dnet о проекте
bugtraq.ru / форум / sysadmin
Имя Пароль
ФОРУМ
если вы видите этот текст, отключите в настройках форума использование JavaScript
регистрация





Легенда:
  новое сообщение
  закрытая нитка
  новое сообщение
  в закрытой нитке
  старое сообщение
  • Напоминаю, что масса вопросов по функционированию форума снимается после прочтения его описания.
  • Новичкам также крайне полезно ознакомиться с данным документом.
сделай так... 28.11.02 18:47  Число просмотров: 1041
Автор: ZaDNiCa <indeed ZaDNiCa> Статус: Elderman
Отредактировано 28.11.02 19:02  Количество правок: 1
<"чистая" ссылка>
> имелось ввиду де эти файлы на первом или на 2 сиди?
по логике вещей должны быть на первом.. однако на 100% не уверен - нет под рукой мандраки..
<sysadmin>
вопрос про Mandrake 9.0 в частности, и линух мандрак вообще 27.11.02 14:46  
Автор: iokana <iokana jon> Статус: Member
<"чистая" ссылка>
непонятная вещь, при установке любого пакета rpm и srpm :
если ставить в лоб, ну там из-под Хсов, или же rpm -ivh пакет, rpm --install и т.п. никакаих вопросов не возникает - все крутиться и вертиться,
а вот ежели захотеть перекомпилить, пересобрать (поправить что-нть) , то тут-то и непонятное возникает:
например:
rpm -bb пакет. src.rpm (-ba и прочее все что угодно)
или там:
rpm --rebuild пакет. src.rpm
ответ одинаковЖ
/usr/lib/rpm/rmpb: Permission denied

смотрел, может прав доступа(записи и прочего) нет, нифига менял chown root'у и прочие rwx'ы но че-та пока никак - Permission denied

сталкивался ли кто с подобным и что делать????
вопрос про Mandrake 9.0 в частности, и линух мандрак вообще 27.11.02 15:17  
Автор: ZaDNiCa <indeed ZaDNiCa> Статус: Elderman
<"чистая" ссылка>
> /usr/lib/rpm/rmpb: Permission denied
посмотри есть ли права на запуск файла /usr/lib/rpm/rpmb, если нет chmod +x
/usr/lib/rpm/rpmb

попробуй rpm -vv --rebuild xxx.src.rpm
вопрос про Mandrake 9.0 в частности, и линух мандрак вообще 27.11.02 15:52  
Автор: iokana <iokana jon> Статус: Member
<"чистая" ссылка>
> > /usr/lib/rpm/rmpb: Permission denied
> посмотри есть ли права на запуск файла /usr/lib/rpm/rpmb,
> если нет chmod +x
> /usr/lib/rpm/rpmb

файла или папки?? там кажись тока папка есть такая, хотя щас точно не скажу, машинка далеко пока что....


> попробуй rpm -vv --rebuild xxx.src.rpm
у меня это 27.11.02 16:55  
Автор: ZaDNiCa <indeed ZaDNiCa> Статус: Elderman
<"чистая" ссылка>
запускаемый файл.. он из пакета rpm-build
оказалось, что плохо встал rpm... 28.11.02 17:08  
Автор: iokana <iokana jon> Статус: Member
<"чистая" ссылка>
> запускаемый файл.. он из пакета rpm-build
у меня rpmb - папка !!! мля....
оказалось, что плохо встал rpm .... помниться, что при установке, кажется, были ошибки устаноки пакетов, -- болванка была плохо зарезана...
1) как его - rpm - доставить или переставить?? обязательно ли из 9-ой мандраки брать rpm_build ну или вообще все rpm ??
2) и вообще - что конкретно ставить можно типа прям rpm -ivh rpm* или как лучше???
и на первое - можно ли , скажем, поставить rpm из мандраки 8.2 ? а то ведь он проверяет зависимости я в прямую не встанет???
сделай так 28.11.02 17:48  
Автор: ZaDNiCa <indeed ZaDNiCa> Статус: Elderman
<"чистая" ссылка>
смотри какие в шапке пакеты связанные с рпм:
rpm-python
rpm-build
rpm

попробуй переставить тока rpm-build (вынеся старую версию)

> 2) и вообще - что конкретно ставить можно типа прям rpm
> -ivh rpm* или как лучше???
достаточно rpm -i xxx.rpm (vh - юзается только для визуализации)

> из мандраки 8.2 ? а то ведь он проверяет зависимости я в
> прямую не встанет???
если не ставится - инсталь так
rpm -ihv xxx.rpm --nodeps
но лучше качни с инета именно ту версию rpm-build что у тебя и стояла
сделай так... 28.11.02 18:17  
Автор: iokana <iokana jon> Статус: Member
<"чистая" ссылка>
> попробуй переставить тока rpm-build (вынеся старую версию)

> > 2) и вообще - что конкретно ставить можно типа
> прям rpm
> > -ivh rpm* или как лучше???
> достаточно rpm -i xxx.rpm (vh - юзается только для
> визуализации)
имелось ввиду де эти файлы на первом или на 2 сиди?
сделай так... 28.11.02 18:47  
Автор: ZaDNiCa <indeed ZaDNiCa> Статус: Elderman
Отредактировано 28.11.02 19:02  Количество правок: 1
<"чистая" ссылка>
> имелось ввиду де эти файлы на первом или на 2 сиди?
по логике вещей должны быть на первом.. однако на 100% не уверен - нет под рукой мандраки..
значит получилось так... 29.11.02 22:36  
Автор: iokana <iokana jon> Статус: Member
<"чистая" ссылка>
а вернее не получлось:
после всех изысканий при попытках установки rpm-build получил следуещее:
autoconf is needed by rpm-build-4.0.4
automake is needed by rpm-build-4.0.4
gcc-c++ is needed by rpm-build-4.0.4
libtool is needed by rpm-build-4.0.4
spec-helper is needed by rpm-build-4.0.4


тут еще вопрос - если rpm снести совсем, типа rpm -e rpm-4.0.4--nodeps как его без него постваить, каким способом ?? ведь rpm нет?7????

ну и на последок - при утстановке самой системы что желательно(обязательно) ставить помимо мандраковских замочков(обзательных компонент) ??? какие компилеры, интерпритаторы и т.п. не для работы программера, а для, ну например, правильной работы того же rpm (gcc-c++) ??????
значит получилось так... 02.12.02 18:29  
Автор: Ktirf <Æ Rusakov> Статус: Elderman
<"чистая" ссылка>
> тут еще вопрос - если rpm снести совсем, типа
> rpm -e rpm-4.0.4--nodeps как его без
> него постваить, каким способом ?? ведь rpm нет?7????
У меня была аналогичная проблема, когда мне нужно было проапгрейдить старый rpm. Классическая шутка в стиле pkunzip.zip - в сети все rpm*.rpm новых версий попадались запакованные новым же rpm'ом. Вышел из положения, поставив из tar.gz. Но в собственной базе установленных пакетов rpm после этого отсутствует, конечно.
значит получилось так... 02.12.02 10:46  
Автор: ZaDNiCa <indeed ZaDNiCa> Статус: Elderman
<"чистая" ссылка>
> а вернее не получлось:
> после всех изысканий при попытках установки rpm-build
> получил следуещее:
> autoconf is needed by rpm-build-4.0.4
> automake is needed by rpm-build-4.0.4
> gcc-c++ is needed by rpm-build-4.0.4
> libtool is needed by rpm-build-4.0.4
> spec-helper is needed by rpm-build-4.0.4

у тебя в системе не все компоненты (к примеру gcc-c++) устанновлены, поставь их и потом только переставь rpm-build

> ну и на последок - при утстановке самой системы что
> желательно(обязательно) ставить помимо мандраковских
> замочков(обзательных компонент) ??? какие компилеры,
> интерпритаторы и т.п. не для работы программера, а для, ну
> например, правильной работы того же rpm (gcc-c++) ??????
ну это выясняется только путем экспериментов... кроме того разве в установке мандраки при добавлении какого-то пакета разве нет проверки зависимых пакетов?
nen 29.11.02 22:04  
Автор: iokana <iokana jon> Статус: Member
<"чистая" ссылка>
да, а на третьем rpm-rebuilder-0.7-1mdk.noarch.rpm есть??? 28.11.02 20:04  
Автор: iokana <iokana jon> Статус: Member
<"чистая" ссылка>
там на 1сиди: 28.11.02 19:59  
Автор: iokana <iokana jon> Статус: Member
<"чистая" ссылка>
rpmdrake-2.0-27mdk.i586.rpm
rpmstats-0.3-4mdk.i586.rpm
rpmtools-4.5-2mdk.i586.rpm
rpm-4.0.4-19mdk.i586.rpm
rpm-helper-0.6-1mdk.noarch.rpm

а на втором:
rpmlint-0.47-1mdk.noarch.rpm
rpm-build-4.0.4-19mdk.i586.rpm
rpm-devel-4.0.4-19mdk.i586.rpm
rpm-python-4.0.4-19mdk.i586.rpm

по идее нада rpm-build-4.0.4-19mdk.i586.rpm и как ты говорил rpm-python-4.0.4-19mdk.i586.rpm тока вот нафига rpm-python-4.0.4-19mdk.i586.rpm ???
+ на всякий случай после переустановки rpm сказать rpm --rebuilddb. 28.11.02 18:07  
Автор: Night Knight [HZTeam.msk] <George Fedosejev> Статус: Member
<"чистая" ссылка>
хорошо, попробуем.. 27.11.02 20:16  
Автор: iokana <iokana jon> Статус: Member
<"чистая" ссылка>
1




Rambler's Top100
Рейтинг@Mail.ru


  Copyright © 2001-2022 Dmitry Leonov   Page build time: 0 s   Design: Vadim Derkach