информационная безопасность
без паники и всерьез
 подробно о проектеRambler's Top100
Атака на InternetСтрашный баг в WindowsСетевые кракеры и правда о деле Левина
BugTraq.Ru
Русский BugTraq
 Анализ криптографических сетевых... 
 Модель надежности двухузлового... 
 Специальные марковские модели надежности... 
 Microsoft сообщила о 44 миллионах... 
 Множественные уязвимости в VNC 
 Шестой Perl превратится в Raku,... 
главная обзор RSN блог библиотека закон бред форум dnet о проекте
bugtraq.ru / форум / networking
Имя Пароль
ФОРУМ
если вы видите этот текст, отключите в настройках форума использование JavaScript
регистрация





Легенда:
  новое сообщение
  закрытая нитка
  новое сообщение
  в закрытой нитке
  старое сообщение
  • Напоминаю, что масса вопросов по функционированию форума снимается после прочтения его описания.
  • Новичкам также крайне полезно ознакомиться с данным документом.
есть мысль 08.12.04 21:02  Число просмотров: 2994
Автор: LLL <Алексей> Статус: Member
<"чистая" ссылка>
> Есть freebsd 5.1-RELEASE, пытаюсь туда взгромоздить сервер
> pppoe в связке pppd (2.3.11) + rp-pppoe (3.5). Ставил все
> из портов, виндовский клиент (Raspppoe) видит сервис pppoe
> после запуска командой /usr/local/sbin/pppoe-server -I xl0
> -L 10.10.0.1 -C name_pppoe_service, но при попытке
> приконнектится (с помощью соединения созданного raspppoe)
> ввыдается 651 ошибка, а в логах пишется : pppd[2516]:
> unrecognized option 'pty'.

У меня в системе pppd имеется только тот, что входит в base, т.е. /usr/sbin/pppd.
У него версия 2.3.5. Сейчас специально скачал исходники pppd 2.3.11, чтобы из "what new" узнать, не появилась ли опция pty уже в версиях 2.3.x, т.к. слышал, что в 2.4.x она уже есть.
Оказалось, что появилась в 2.3.7.
Как я понимаю, pppd 2.3.11 ставилась из портов/пакаджей, т.е. в /usr/local/, и, судя по всему, в описанной ситуации pppoe пытается запустить родной /usr/sbin/pppd, который староват для pppoe. Значит надо объяснить pppoe, что pppd лучше искать в /usr/local/..., а не в /usr/sbin (как именно, не подскажу, т.к. у меня нет этой штуки вместе с ее мануалами).
<networking>
pppoe 08.12.04 13:39  
Автор: dron <Ivanov Andrey> Статус: Member
<"чистая" ссылка>
Есть freebsd 5.1-RELEASE, пытаюсь туда взгромоздить сервер pppoe в связке pppd (2.3.11) + rp-pppoe (3.5). Ставил все из портов, виндовский клиент (Raspppoe) видит сервис pppoe после запуска командой /usr/local/sbin/pppoe-server -I xl0 -L 10.10.0.1 -C name_pppoe_service, но при попытке приконнектится (с помощью соединения созданного raspppoe) ввыдается 651 ошибка, а в логах пишется : pppd[2516]: unrecognized option 'pty'.
Начал копаться с pppd в файле configure не нашел поддержки для 5.1-RELEASE, последнее о чем идет там речь, так это о freebsd 3.0, соответсвенно при попытке скомпилить pppd вручную выдается

Support for this system has not been included
in this distribution. Sorry.

Может кто сталкивался???
есть мысль 08.12.04 21:02  
Автор: LLL <Алексей> Статус: Member
<"чистая" ссылка>
> Есть freebsd 5.1-RELEASE, пытаюсь туда взгромоздить сервер
> pppoe в связке pppd (2.3.11) + rp-pppoe (3.5). Ставил все
> из портов, виндовский клиент (Raspppoe) видит сервис pppoe
> после запуска командой /usr/local/sbin/pppoe-server -I xl0
> -L 10.10.0.1 -C name_pppoe_service, но при попытке
> приконнектится (с помощью соединения созданного raspppoe)
> ввыдается 651 ошибка, а в логах пишется : pppd[2516]:
> unrecognized option 'pty'.

У меня в системе pppd имеется только тот, что входит в base, т.е. /usr/sbin/pppd.
У него версия 2.3.5. Сейчас специально скачал исходники pppd 2.3.11, чтобы из "what new" узнать, не появилась ли опция pty уже в версиях 2.3.x, т.к. слышал, что в 2.4.x она уже есть.
Оказалось, что появилась в 2.3.7.
Как я понимаю, pppd 2.3.11 ставилась из портов/пакаджей, т.е. в /usr/local/, и, судя по всему, в описанной ситуации pppoe пытается запустить родной /usr/sbin/pppd, который староват для pppoe. Значит надо объяснить pppoe, что pppd лучше искать в /usr/local/..., а не в /usr/sbin (как именно, не подскажу, т.к. у меня нет этой штуки вместе с ее мануалами).
абсолютно верно! 08.12.04 23:19  
Автор: dron <Ivanov Andrey> Статус: Member
<"чистая" ссылка>
> У меня в системе pppd имеется только тот, что входит в
> base, т.е. /usr/sbin/pppd.
> У него версия 2.3.5. Сейчас специально скачал исходники
> pppd 2.3.11, чтобы из "what new" узнать, не появилась ли
> опция pty уже в версиях 2.3.x, т.к. слышал, что в 2.4.x она
> уже есть.
> Оказалось, что появилась в 2.3.7.
> Как я понимаю, pppd 2.3.11 ставилась из портов/пакаджей,
> т.е. в /usr/local/, и, судя по всему, в описанной ситуации
> pppoe пытается запустить родной /usr/sbin/pppd, который
> староват для pppoe. Значит надо объяснить pppoe, что pppd
> лучше искать в /usr/local/..., а не в /usr/sbin (как
> именно, не подскажу, т.к. у меня нет этой штуки вместе с ее
> мануалами).
все дело было в том что в /usr/sbin валялся непонятный бинарник pppd, я просто после очередной деинсталяции обратил внимание на то что он не удалился, удалил вручную, сделал в очередной раз из портов make install, и увидел что pppd в /usr/sbin не появился,а появился гад в /usr/local/sbin, соответсвенно rp-pppoe до этого использовало pppd из /usr/sbin, который был левым, как тока она поняло что надо использовать другой pppd все встало на свои места, блин из-за такой фигни стока времени потеряно!!!!! Спасибо!!
1






Rambler's Top100
Рейтинг@Mail.ru


  Copyright © 2001-2019 Dmitry Leonov   Page build time: 0 s   Design: Vadim Derkach