информационная безопасность
без паники и всерьез
 подробно о проектеRambler's Top100
Страшный баг в WindowsГде водятся OGRыЗа кого нас держат?
BugTraq.Ru
Русский BugTraq
 Анализ криптографических сетевых... 
 Модель надежности двухузлового... 
 Специальные марковские модели надежности... 
 Линуксовый ботнет, распространяющийся... 
 Конец поддержки Internet Explorer 
 Рекордное число уязвимостей в 2021 
главная обзор RSN блог библиотека закон бред форум dnet о проекте
bugtraq.ru / форум / beginners
Имя Пароль
ФОРУМ
если вы видите этот текст, отключите в настройках форума использование JavaScript
регистрация





Легенда:
  новое сообщение
  закрытая нитка
  новое сообщение
  в закрытой нитке
  старое сообщение
  • Напоминаю, что масса вопросов по функционированию форума снимается после прочтения его описания.
  • Новичкам также крайне полезно ознакомиться с данным документом.
Господа, будьте снисходительны, не бросайтесь сразу штрафовать за, как вам кажется, глупые вопросы - beginners на то и beginners.
RE: конфиг 15.06.05 13:05  Число просмотров: 1696
Автор: Blade Статус: Незарегистрированный пользователь
<"чистая" ссылка>

> <путь к деплою>\FILES\SETUP -> там файл -
> SETUP.INI (скорее всего, он там - один)
>
> путь - место откуда инсталлер тянет файлы. В момент запуска
> он может на некоторое время показывать его. Если нет,
> выдерни патчкорд из машины и добейся его запуска - он
> обматерится, что по указанному пути нифига найти не может -
> вот это место и есть.

Путь к деплою откуда инсталлер тянет файлы - существующий и доступен. в \FILES\SETUP нашел файл SETUP.INI. Но в пропертях у него дата модификации явно раньше чем появилась у меня проблема. (Created: 20 ceнтябpя 2002 г Modified 7 мapтa 2001 г)
<beginners>
Глючный Отлук 10.06.05 13:53  
Автор: Blade Статус: Незарегистрированный пользователь
<"чистая" ссылка>
ОС WinXp SP1. После каждого запуска Microsoft Outlook 2002 (10.2627.2625) [Взято из About] - примерно на пол минуты появляется диалог Windows Installer, идет юзание CPU примерно на 30%. Когда диалог Windows Installer пропадает, то в процессах появляется Winword.exe с Mem Usage более 10000К.
Иногда Windows Installer появляется при открытии некоторых писем.
У кого такое ещё проявлялось и как с эитм боролись?
запускается из пользователя с какими прававми? 10.06.05 14:33  
Автор: ZaDNiCa <indeed ZaDNiCa> Статус: Elderman
<"чистая" ссылка>
Пользователь или Опытный пользователь/Администратор?
Почта рабочая. Настроена на скачивание с местного Exchange... 10.06.05 14:55  
Автор: Blade Статус: Незарегистрированный пользователь
<"чистая" ссылка>
Почта рабочая. Настроена на скачивание с местного Exchange server. При запуске отлука Авторизация - автоматическая - в настройках установленно брать пароль и логин такой же как и при логине в домен. Почтовый сервер тоже в этом же домене. При запуске отлука, также запрашивается пароль на Personal Folders - вся почта скачивается потом на комп из сервака. В этот момент и появляется Windows Installer.
На компе у меня права администратора.
попробуй вот что 10.06.05 16:18  
Автор: ZaDNiCa <indeed ZaDNiCa> Статус: Elderman
<"чистая" ссылка>
1. проверить запуск word или excel - запускается ли инсталер?
2. на том же компе под другим логином запустить несколько раз outlook без настройки учетной записи - будет ли стартовать инсталлер?
3. попробовать настроить под этим же логином свою учетную запись и посмотреть повлияет ли это на запуск
4. удалить учетную запись Exchange под своим логином и снова проверить
Выложи результаты - попробуем что-то подсказать
добавлю 10.06.05 17:30  
Автор: Deviator <n/a> Статус: Member
<"чистая" ссылка>
...
5. Проверь, не установлен-ли в качестве дефлотного редактора писем - Ворд (очень похоже).
6. Если Офис ставился с сетевого деплоя, найди того, кто делал деплой и выясни, не менялся-ли конфиг. файл в последнее время (перед тем, как возникли проблемы)
Результат 10.06.05 19:25  
Автор: Blade Статус: Незарегистрированный пользователь
<"чистая" ссылка>
1. При запуске ворда или ёксел - installer не запускается.
2. Залогинился под другим логином (не доменным, а логином Administrator этого компа). Учетной записи не было. При запуске Отлука - Installer сразу поднимается. Пробовал несколько раз.
3. 4. Не делал, так как не имеет смысла, раз без учетной записи тоже Installer поднимается.
5. Ворд в качестве дефалтового редактора был действительно установлен - сняг галку с этого чекбокса - winword.exe перестал оставаться в процессах, Но Installer все равно поднимается при запуске и чтении некоторых писем.
6. Да, офис ставился по сети, но админ сейчас в отпуске и узнать ничего про конфиги не могу. Где это конфиг файл должен лежать? Может я сам могу посмотреть дату его изменения.
конфиг 11.06.05 01:16  
Автор: Deviator <n/a> Статус: Member
Отредактировано 11.06.05 01:17  Количество правок: 1
<"чистая" ссылка>
> 6. Да, офис ставился по сети, но админ сейчас в отпуске и
> узнать ничего про конфиги не могу. Где это конфиг файл
> должен лежать? Может я сам могу посмотреть дату его
> изменения.

<путь к деплою>\FILES\SETUP -> там файл - SETUP.INI (скорее всего, он там - один)

путь - место откуда инсталлер тянет файлы. В момент запуска он может на некоторое время показывать его. Если нет, выдерни патчкорд из машины и добейся его запуска - он обматерится, что по указанному пути нифига найти не может - вот это место и есть.
RE: конфиг 15.06.05 13:05  
Автор: Blade Статус: Незарегистрированный пользователь
<"чистая" ссылка>

> <путь к деплою>\FILES\SETUP -> там файл -
> SETUP.INI (скорее всего, он там - один)
>
> путь - место откуда инсталлер тянет файлы. В момент запуска
> он может на некоторое время показывать его. Если нет,
> выдерни патчкорд из машины и добейся его запуска - он
> обматерится, что по указанному пути нифига найти не может -
> вот это место и есть.

Путь к деплою откуда инсталлер тянет файлы - существующий и доступен. в \FILES\SETUP нашел файл SETUP.INI. Но в пропертях у него дата модификации явно раньше чем появилась у меня проблема. (Created: 20 ceнтябpя 2002 г Modified 7 мapтa 2001 г)
ещё даты 15.06.05 13:22  
Автор: Deviator <n/a> Статус: Member
<"чистая" ссылка>
> Путь к деплою откуда инсталлер тянет файлы - существующий и
> доступен. в \FILES\SETUP нашел файл SETUP.INI. Но в
> пропертях у него дата модификации явно раньше чем появилась
> у меня проблема. (Created: 20 ceнтябpя 2002 г Modified
> 7 мapтa 2001 г)
Посмотри даты файлов .MSI там-же (в корне), если они свежие, значит производилось обновление самого пакета и тебе, возможно, надо обновить инсталляцию на твоей машине.
Re: ещё даты 15.06.05 14:45  
Автор: Blade Статус: Незарегистрированный пользователь
<"чистая" ссылка>

> Посмотри даты файлов .MSI там-же (в корне), если они
> свежие, значит производилось обновление самого пакета и
> тебе, возможно, надо обновить инсталляцию на твоей машине.

В корне офиса(где находится setup.exe) лежат два msi файла (OWC10.MSI и PROPLUS.MSI) они также не обновлялись с 2002 года..
Но я всё равно решил обновить инсталляцию - запустил setup, там выбрал:
Repair Office - Restore your Microsoft Office XP Professional with
FrontPage installation to its original state.
Всё обновилось без ошибок. Запускаю Отлук. Но этот чёртов windows installer всё равно появляется...
обновление инсталляции 15.06.05 15:30  
Автор: Deviator <n/a> Статус: Member
<"чистая" ссылка>
> Но я всё равно решил обновить инсталляцию - запустил setup,
> там выбрал:
> Repair Office - Restore your Microsoft Office XP
> Professional with
> FrontPage installation to its original state.
> Всё обновилось без ошибок. Запускаю Отлук. Но этот чёртов
> windows installer всё равно появляется...
Попробуй обновить так:
msiexec /i <путь к деплою>\proplus.msi REINSTALL=ALL REINSTALLMODE=vomu
вроде, ничего не напутал :-)
Re: обновление инсталляции 15.06.05 17:01  
Автор: Blade Статус: Незарегистрированный пользователь
<"чистая" ссылка>

> Попробуй обновить так:
> msiexec /i <путь к деплою>\proplus.msi REINSTALL=ALL
> REINSTALLMODE=vomu
> вроде, ничего не напутал :-)

Попробовал, после этой команды появляется диалог Windows installer с инфой и кн. ОК
Вот инфа:

Windows ® Installer. V 3.01.4000.1823

msiexec /Option <Required Parameter> [Optional Parameter]

Install Options
</package | /i> <Product.msi>
Installs or configures a product
/a <Product.msi>
Administrative install - Installs a product on the network
/j<u|m> <Product.msi> [/t <Transform List>] [/g <Language ID>]
Advertises a product - m to all users, u to current user
</uninstall | /x> <Product.msi | ProductCode>
Uninstalls the product
Display Options
/quiet
Quiet mode, no user interaction
/passive
Unattended mode - progress bar only
/q[n|b|r|f]
Sets user interface level
n - No UI
b - Basic UI
r - Reduced UI
f - Full UI (default)
/help
Help information
Restart Options
/norestart
Do not restart after the installation is complete
/promptrestart
Prompts the user for restart if necessary
/forcerestart
Always restart the computer after installation
Logging Options
/l[i|w|e|a|r|u|c|m|o|p|v|x|+|!] <LogFile>
i - Status messages
w - Nonfatal warnings
e - All error messages
a - Start up of actions
r - Action-specific records
u - User requests
c - Initial UI parameters
m - Out-of-memory or fatal exit information
o - Out-of-disk-space messages
p - Terminal properties
v - Verbose output
x - Extra debugging information
+ - Append to existing log file
! - Flush each line to the log
* - Log all information, except for v and x options
/log <LogFile>
Equivalent of /l* <LogFile>
Update Options
/update <Update1.msp>[;Update2.msp]
Applies update(s)
/uninstall <PatchCodeGuid>[;Update2.msp] /package <Product.msi | ProductCode>
Remove update(s) for a product
Repair Options
/f[p|e|c|m|s|o|d|a|u|v] <Product.msi | ProductCode>
Repairs a product
p - only if file is missing
o - if file is missing or an older version is installed (default)
e - if file is missing or an equal or older version is installed
d - if file is missing or a different version is installed
c - if file is missing or checksum does not match the calculated value
a - forces all files to be reinstalled
u - all required user-specific registry entries (default)
m - all required computer-specific registry entries (default)
s - all existing shortcuts (default)
v - runs from source and recaches local package
Setting Public Properties
[PROPERTY=PropertyValue]

Consult the Windows ® Installer SDK for additional documentation on the
command line syntax.

Copyright © Microsoft Corporation. All rights reserved.
Portions of this software are based in part on the work of the Independ

Нажимаю ОК. Недолгое подвисание и всё. Обновилось?
Запускаю отлук. Проблема осталась.
Кстати, забыл сразу сказать в описании проблемы, что когда инсталлер поднимается - пару раз дергается флоп, как буд-то что-то ищет...
проверь 16.06.05 08:49  
Автор: Deviator <n/a> Статус: Member
Отредактировано 16.06.05 08:50  Количество правок: 2
<"чистая" ссылка>
[...]
> Попробовал, после этой команды появляется диалог Windows
> installer с инфой и кн. ОК
[...]
> Нажимаю ОК. Недолгое подвисание и всё. Обновилось?
> Запускаю отлук. Проблема осталась.
> Кстати, забыл сразу сказать в описании проблемы, что когда
> инсталлер поднимается - пару раз дергается флоп, как буд-то
> что-то ищет...

Появление инфы - признак того, что инсталлеру что-то не наравится (ключи проверил - всё верно, обязано работать нормально). Проверь, точность указания пути, саму строку скопируй через буфер, во избежание ошибок (регистр имеет значение). Строка ещё раз:

msiexec /i \\<server&path>\proplus.msi REINSTALL=ALL REINSTALLMODE=vomu

не забудь заменить <server&path> на свой путь
проверил 16.06.05 14:17  
Автор: Blade Статус: Незарегистрированный пользователь
<"чистая" ссылка>

> Появление инфы - признак того, что инсталлеру что-то не
> наравится (ключи проверил - всё верно, обязано работать
> нормально). Проверь, точность указания пути, саму строку
> скопируй через буфер, во избежание ошибок (регистр имеет
> значение). Строка ещё раз:
>
> msiexec /i \\<server&path>\proplus.msi
> REINSTALL=ALL REINSTALLMODE=vomu
>
> не забудь заменить <server&path> на свой путь

Если сам PROPLUS.MSI запустить - то установка запускается.
проверил 16.06.05 14:08  
Автор: Blade Статус: Незарегистрированный пользователь
<"чистая" ссылка>

> Появление инфы - признак того, что инсталлеру что-то не
> наравится (ключи проверил - всё верно, обязано работать
> нормально). Проверь, точность указания пути, саму строку
> скопируй через буфер, во избежание ошибок (регистр имеет
> значение). Строка ещё раз:
>
> msiexec /i \\<server&path>\proplus.msi
> REINSTALL=ALL REINSTALLMODE=vomu
>
> не забудь заменить <server&path> на свой путь

Да, я копирую через буфер туда свой путь msiexec /i \\mailbox\Distr\Office\Office XP\proplus.msi REINSTALL=ALL REINSTALLMODE=vomu (mailbox - сервер, в фолдере Office XP - лежит PROPLUS.MSI) Но снова появляется диалог с инфой
странно это 16.06.05 14:59  
Автор: Deviator <n/a> Статус: Member
<"чистая" ссылка>
> Да, я копирую через буфер туда свой путь msiexec /i
> \\mailbox\Distr\Office\Office XP\proplus.msi REINSTALL=ALL
> REINSTALLMODE=vomu (mailbox - сервер, в фолдере Office XP
> - лежит PROPLUS.MSI) Но снова появляется диалог с инфой

Раз есть диалог с инфой - значит с ключами(опциями) что-то не в порядке (а я их проверил). Запуск файла .MSI даблкликом - не одно и то же. В чём причина такого поведения - сказать не могу. Обязано работать! Если не найдёшь причину - попробуй полностью деинсталировать Офис и поставить его снова, а не поверх. Если решишь удалять Офис, делай это от доп. пакетов (если они есть) к основному (его последним).
1




Rambler's Top100
Рейтинг@Mail.ru


  Copyright © 2001-2022 Dmitry Leonov   Page build time: 0 s   Design: Vadim Derkach