информационная безопасность
без паники и всерьез
 подробно о проектеRambler's Top100
Сетевые кракеры и правда о деле ЛевинаВсе любят мед
BugTraq.Ru
Русский BugTraq
 Анализ криптографических сетевых... 
 Модель надежности двухузлового... 
 Специальные марковские модели надежности... 
 Ростелеком заподозрили в попытке... 
 Линуксовый ботнет, распространяющийся... 
 Конец поддержки Internet Explorer 
главная обзор RSN блог библиотека закон бред форум dnet о проекте
bugtraq.ru / форум / operating systems
Имя Пароль
ФОРУМ
если вы видите этот текст, отключите в настройках форума использование JavaScript
регистрация





Легенда:
  новое сообщение
  закрытая нитка
  новое сообщение
  в закрытой нитке
  старое сообщение
  • Напоминаю, что масса вопросов по функционированию форума снимается после прочтения его описания.
  • Новичкам также крайне полезно ознакомиться с данным документом.
[Unix] FreeBSD 5.3 Проблема со сборкой x11-toolkits/linux-gtk2 20.07.05 12:46  
Автор: stasyan Статус: Незарегистрированный пользователь
<"чистая" ссылка>
Здравствуйте, уважаемые.
Обновил порты, помучался, пока собрал все необходимое, а теперь такое вот

root:/usr/ports/x11-toolkits/linux-gtk2-> make FORCE_PKG_REGISTER= install
===> Installing for linux-gtk2-2.2.1_5
===> linux-gtk2-2.2.1_5 depends on file: /compat/linux/usr/lib/libglib-2.0.so.0 - not found
===> Verifying install for /compat/linux/usr/lib/libglib-2.0.so.0 in /usr/ports/devel/linux-glib2
===> Returning to build of linux-gtk2-2.2.1_5
===> linux-gtk2-2.2.1_5 depends on file: /compat/linux/usr/lib/libatk-1.0.so.0 - not found
===> Verifying install for /compat/linux/usr/lib/libatk-1.0.so.0 in /usr/ports/accessibility/linux-atk
===> Returning to build of linux-gtk2-2.2.1_5
===> linux-gtk2-2.2.1_5 depends on file: /compat/linux/usr/lib/libjpeg.so.62 - not found
===> Verifying install for /compat/linux/usr/lib/libjpeg.so.62 in /usr/ports/graphics/linux-jpeg
===> Returning to build of linux-gtk2-2.2.1_5
===> linux-gtk2-2.2.1_5 depends on file: /compat/linux/usr/lib/libpng12.so.0.1.2.7 - not found
===> Verifying install for /compat/linux/usr/lib/libpng12.so.0.1.2.7 in /usr/ports/graphics/linux-png
===> Returning to build of linux-gtk2-2.2.1_5
===> linux-gtk2-2.2.1_5 depends on file: /compat/linux/usr/lib/libtiff.so.3.6.1 - not found
===> Verifying install for /compat/linux/usr/lib/libtiff.so.3.6.1 in /usr/ports/graphics/linux-tiff
===> Returning to build of linux-gtk2-2.2.1_5
===> linux-gtk2-2.2.1_5 depends on file: /compat/linux/usr/lib/libpango-1.0.so.0.200.1 - found
===> linux-gtk2-2.2.1_5 depends on executable: rpm - found
===> linux-gtk2-2.2.1_5 depends on file: /compat/linux/etc/redhat-release - found
===> linux-gtk2-2.2.1_5 depends on file: /compat/linux/usr/X11R6/lib/libXrender.so.1 - not found
===> Verifying install for /compat/linux/usr/X11R6/lib/libXrender.so.1 in /usr/ports/x11/linux-XFree86-libs
===> Vulnerability check disabled, database not found
===> Extracting for linux-XFree86-libs-4.3.99.902_3
=> Checksum OK for rpm/i386/suse/XFree86-libs-4.3.99.902-43.35.3.i586.rpm.
===> Patching for linux-XFree86-libs-4.3.99.902_3
===> linux-XFree86-libs-4.3.99.902_3 depends on executable: rpm - found
===> Configuring for linux-XFree86-libs-4.3.99.902_3
===> Installing for linux-XFree86-libs-4.3.99.902_3
===> linux-XFree86-libs-4.3.99.902_3 depends on file: /compat/linux/usr/lib/libfontconfig.so.1 - found
===> linux-XFree86-libs-4.3.99.902_3 depends on file: /compat/linux/etc/redhat-release - found
17214 blocks
===> Generating temporary packing list
===> Registering installation for linux-XFree86-libs-4.3.99.902_3
===> SECURITY REPORT:
This port has installed the following files which may act as network
servers and may therefore pose a remote security risk to the system.
/usr/local/usr/X11R6/lib/libICE.so.6.3
/usr/local/usr/X11R6/lib/libXfont.so.1.5

If there are vulnerabilities in these programs there may be a security
risk to the system. FreeBSD makes no guarantee about the security of
ports included in the Ports Collection. Please type 'make deinstall'
to deinstall the port if this is a concern.

For more information, and contact details about the security
status of this software, see the following webpage:
http://xfree86.org
===> Returning to build of linux-gtk2-2.2.1_5
===> Generating temporary packing list
gtk2-2.2.1-4.1.legacy.i386.rpm
ELF interpreter /lib/ld-linux.so.2 not found
Abort trap
*** Error code 134

Stop in /usr/xlam/ports/x11-toolkits/linux-gtk2.

есть /usr/compat/linux/lib/ld-linux.so.2, ссылается на ld-2.3.2.so, вот этой либы нигде не было. ок, интернет большой, нашел какую-то на 105 килобайт, сделал линк на нее /lib/ld-linux.so.2, и все равно такой спотыкач :(

чувствую, что-то я упустил. подскажите, что именно?
linux_enable=yes? 20.07.05 13:41  
Автор: ZaDNiCa <indeed ZaDNiCa> Статус: Elderman
<"чистая" ссылка>
в rc.conf включена ли поддержка бинарников linux (linux_enable=yes)
установлен ли порт linux-base?
kldstat 20.07.05 14:02  
Автор: stasyan Статус: Незарегистрированный пользователь
Отредактировано 20.07.05 14:15  Количество правок: 1
<"чистая" ссылка>
> в rc.conf включена ли поддержка бинарников linux
> (linux_enable=yes)
> установлен ли порт linux-base?

kldstat
Id Refs Address Size Name
1 23 0xc0400000 5cdad0 kernel
2 1 0xc09ce000 5844 snd_ich.ko
3 2 0xc09d4000 1d4fc sound.ko
4 14 0xc09f2000 537f0 acpi.ko
5 1 0xc1d4d000 5000 linprocfs.ko
6 5 0xc1d56000 17000 linux.ko
7 1 0xc1e0c000 8000 vmmon_up.ko
8 1 0xc1e14000 2000 vmnet.ko
9 1 0xc1e16000 4000 if_tap.ko
10 4 0xc1e1e000 12000 netgraph.ko
11 1 0xc1e34000 4000 ng_ether.ko
12 1 0xc1e38000 5000 ng_bridge.ko
13 1 0xc1e3f000 5000 ng_socket.ko
14 1 0xc1e52000 2000 rtc.ko
15 1 0xc2070000 17000 radeon.ko

установлен порт linux_base-8. сейчас поставил linux_base, обновились некоторые линки в /usr/compat/linux/lib/, результат тот же :(
кажется понял 20.07.05 14:32  
Автор: ZaDNiCa <indeed ZaDNiCa> Статус: Elderman
<"чистая" ссылка>
> установлен порт linux_base-8. сейчас поставил linux_base,
> обновились некоторые линки в /usr/compat/linux/lib/,
> результат тот же :(

либа ld-2.3.2.so из glibc-2.3.2
в linux_base используется glibc-2.2.5 (старый), а вот linux_base-8 и linux_base_rh9 используют glibc-2.3.2 и при установке должна ставиться ld-2.3.2.so
как вариант переставить linux_base-8 и linux_base_rh9 и посмотреть, установится ли ld-2.3.2.so
спасибо. эта либа появилась после установки linux_base_rh9... 21.07.05 16:20  
Автор: stasyan Статус: Незарегистрированный пользователь
<"чистая" ссылка>
> > установлен порт linux_base-8. сейчас поставил
> linux_base,
> > обновились некоторые линки в /usr/compat/linux/lib/,
> > результат тот же :(
>
> либа ld-2.3.2.so из glibc-2.3.2
> в linux_base используется glibc-2.2.5 (старый), а вот
> linux_base-8 и linux_base_rh9 используют glibc-2.3.2 и при
> установке должна ставиться ld-2.3.2.so
> как вариант переставить linux_base-8 и linux_base_rh9 и
> посмотреть, установится ли ld-2.3.2.so

спасибо. эта либа появилась после установки linux_base_rh9. теперь не работает другое :) мораль - обновлять лучше весь мир целиком, а не кусочками

как узнать, какому (возможно, неустановленному) пакету принадлежит та или иная библиотека?
man pkg_info говорит что... 21.07.05 17:16  
Автор: ZaDNiCa <indeed ZaDNiCa> Статус: Elderman
<"чистая" ссылка>
pkg_info -W /path/to/file
1




Rambler's Top100
Рейтинг@Mail.ru


  Copyright © 2001-2022 Dmitry Leonov   Page build time: 0 s   Design: Vadim Derkach