информационная безопасность
без паники и всерьез
 подробно о проектеRambler's Top100
Страшный баг в WindowsАтака на Internet
BugTraq.Ru
Русский BugTraq
 Анализ криптографических сетевых... 
 Модель надежности двухузлового... 
 Специальные марковские модели надежности... 
 Линуксовый ботнет, распространяющийся... 
 Конец поддержки Internet Explorer 
 Рекордное число уязвимостей в 2021 
главная обзор RSN блог библиотека закон бред форум dnet о проекте
bugtraq.ru / форум / web building
Имя Пароль
ФОРУМ
если вы видите этот текст, отключите в настройках форума использование JavaScript
регистрация





Легенда:
  новое сообщение
  закрытая нитка
  новое сообщение
  в закрытой нитке
  старое сообщение
  • Напоминаю, что масса вопросов по функционированию форума снимается после прочтения его описания.
  • Новичкам также крайне полезно ознакомиться с данным документом.
Формы в Лисе и Хроме 07.07.10 03:05  
Автор: Fighter <Vladimir> Статус: Elderman
<"чистая" ссылка>
Есть форма:
<form action="ab.php" method=post>
Логин или e-mail: <br>
<input type=text name="login" value=""> <br> <br>
Пароль: <br>
<input type=password name="passwd" value=""><br>
<input type=checkbox name="remember"> <span style="font-size:8pt;">Подключаться автоматически</span><br><br>
<input type=image name="enter" src="enter.png" alt="Подключится!">
</form>
Лиса и Хром <input type=image name="enter" src="enter.png" alt="Подключится!"> показывают как обычную картинку, при наведении на которую указатель не изменяется и щелчок ничего не дает, отправить форму можно только Enter'ом. Это баг/фича этих браузеров или я чего-то не так делаю? В Опере и ИЕ все работает.
нет, все работает 07.07.10 12:20  
Автор: dl <Dmitry Leonov>
<"чистая" ссылка>
Код вполне стандартный, для очистки совести просто скопировал твой код в локальный файл - и хром, и ff его отработали, как и положено. В сочетании с косяками Оперы я бы сказал, что с системой что-то не то. Если нет второй под рукой, хоть в виртуалке стоит проверить.
Проверил на другой системе - тоже самое. Но, есть одно "но"... 07.07.10 15:34  
Автор: Fighter <Vladimir> Статус: Elderman
Отредактировано 07.07.10 15:39  Количество правок: 1
<"чистая" ссылка>
Проверил форму в чистом виде - работает везде. Похоже косяки с чем-то другим. CSS или что-то еще могло вызвать такой эффект?
простой css вряд ли 07.07.10 15:54  
Автор: dl <Dmitry Leonov>
<"чистая" ссылка>
Если там какие-то обработчики - то кто его знает :)
Я ничего не вешал, только css-верстка. Чессслово! ) 07.07.10 16:44  
Автор: Fighter <Vladimir> Статус: Elderman
<"чистая" ссылка>
Разобрался. 07.07.10 22:44  
Автор: Fighter <Vladimir> Статус: Elderman
<"чистая" ссылка>
Это именно CSS. Один из контейнеров <div>...</div> накладывался на картинку. Причем, в месте наложения в контейнере ничего не было и Опера с ИЕ его игнорировали, а вот Хром и Лис считали, что <input> закрыт.
забавно 08.07.10 12:12  
Автор: dl <Dmitry Leonov>
<"чистая" ссылка>
Ага. Если лень (мою и разработчиков ff&ch) можно считать забавной. 08.07.10 21:59  
Автор: Fighter <Vladimir> Статус: Elderman
<"чистая" ссылка>
1




Rambler's Top100
Рейтинг@Mail.ru


  Copyright © 2001-2022 Dmitry Leonov   Page build time: 0 s   Design: Vadim Derkach